DCC600 problem after pinch rollers replaced

So, this is new to me.

I have a DCC600 that already has a new belt and is also thoroughly clean(ed) and that I use quite a lot. So this week I replaced the pinch rollers with new ones from the DCCMuseum. After I put the mechanism back into the machine, there was a strange problem:

When I load a new tape, the mechanism scans side A for a few seconds, like normal, but then reverses and does the exact same thing on side B.

Then, when I press PLAY it plays for a few seconds and then stops with no audio. Same if I try on side B.
REWINDing or FASTFORWARDing too. It winds for a seconds and then stops. I can try that over and over again.

I have not even been near anything other than the pinch rollers during the procedure. I checked the cables, but they are fitted ok. I took the mechanism out to check and put it back in again, but still the same problem.

What could be the case here? I’m at a loss atm.


1 Like

I did not manage to repair one out of three 2nd gen mechanisms, so I am probably the worst person on the team in this regard.

What happens with an analog tape?

Hi Max,

With analog tape the same thing.


That is strange. During the few seconds, can you see the pinch rollers turn? No looping of the tape? Can you double check if the wired to the head are still ok?


Yes, I can see the pinch rollers turn. There is no looping of the tape, as far as I can tell. The tape seems to do as supposed to. The tape ejects nice with no loops.

I checked the head wires, as far as I can tell they are seated as they should.


The problem is definitely in the mechanism LDU1000, because the problem stays with the mechanism when I swap it with other machines.

And if you replace the old pinchrollers, does the problem go away? If it stays… something else is the matter.

2nd generation…does this transport system ave an optic that controlles the movement? Like a sensor and a mirror wheel? Something wrong there?

I disassembed the mechanism more, and the gear (as in the DrDCC clip https://www.youtube.com/watch?v=OmM2mbbz7F4&ab_channel=DRDCC) is ok.

I rewatched the video and I could not see a mirror wheel so chances are there is no such thing. But then again we did not see all the sides of the pcb or transport.

Perhaps I wasn’t clear, because I don’t know the name of the part I’m trying to describe.

It is a plastic wheel with intermittent foil on it. On top of that there should be an infrared sender and receiver. This monitors the positive movement of the mechanism. If there is no signal from the counter the mechanism may do exactly what you describe. I know it is in portables but I’m not sure if the 2nd gen transport incorporates them…

Hope you find the problem!

1 Like

Hoi @Fretlessfender,

Yes, I know exactly what you mean. :smiley:


1 Like

Just finished a days work with the 600. I think it is solved. It is working for now. I will have to do some more and longer testing, but I will call it a day and do more testing tomorrow.

I sort of had in the back of my mind an idea what the problem was, and @Fretlessfender was absolutely right: it had something to do with the spindles and their sensors.

This particular deck I had repaired in the past. On the most inner part of the drive mechanism, the part where the heads and the pinch rollers are mounted on, there are small PCB’s connected to the spindles. These boards are held in place by two clamps and some of these clamps were broken off when I first got the deck. I had fixed it in the past with superglue. But apparently when changing the pinchrollers I managed to get this board dislocated again. Not a lot, but enough for the infrared sensor to miss the signal I guess. I reseated it to the best of my knowledge and added more glue so it would stay in place better.

Unfortunately I put the mechanism back together again before I could take pictures, so that’s a pity.
But so far so good.



Well done Philip! If it works now… you can trust it will continue to do so!


Of course this happens.
The deck was on a long test, with the tape mechanism extended outside the case, and all tests went fine, as you can read above.
So today I put everything back together again, made everything neat and tidy again, and hooked the machine up and…
#$%&#$%&#%& same problem again.

Apparently the sensor board has come loose again. It probably shifted a few tenths of a mm, enough to throw the sensor off again. I’m afraid that the repair with the glue is not a lasting one and is certainly not durable enough. Maybe I can get it to work again, but then for how long?

So I came up with another solution: I have another DCC600 which has a faulty head. The analog playback is heavily distorted and digital gives a very intermittent signal, more often no signal then a signal at all. But with a good mechanism.
I would like to try to put the good head of my first machine into this second machine with the faulty head.

So my question now is: is it possible to replace the head on a LDU1000?
I have read the Service Manual (if you’re interested page 58 - https://www.reeltoreel.nl/dccfiles/Service_Manuals/Philips_DCC600_SM_PvdM_searchable.pdf), and the instructions for replacing the head seem pretty simple, but when I look in real life at the head mounting, I hesitate how to proceed exactly. Has anyone ever done it before and maybe has any tips for me?


Not sure how many people except @drdcc have done it.

Maybe I’ll be first then :grimacing: :grimacing:

I’m sorry but…
Isn’t it simpler to replace the sensors? Or is there more damage in the existing mechanism?

If you do change the head… here is something to think about:

  1. Measure the position of the head as close as possible…
  2. If you need to release the 2 screws with lacquer on them, count the rotations of the screws until they come free…
  3. Replace head with 1 and 2 in mind…
  4. Put the device in service mode and insert a prerecorded tape
  5. Select headfault mode in service mode…
  6. Adjust accordingly untill you see 0000000, make tiny adjustment, you should be in the ball-park…

I never did this myself but that is how I would approach it.
I hope it helps!

We have replaced the head and electronics several times and it will work perfectly.
You just have to replace the read-write board as well.



Ok @Fretlessfender and @Ralf, thanks for the feedback.
I will try to exchange the heads.
Ralf, could you give me a hint how to start, because the first step is puzzling for me.

Remove bearing clamp, what and where is that?


1 Like

You don’t need to do that, you can replace the entire head assembly including read-/write-board if it is not damaged.