DCC175 Software on Dell Inspiron 8200

Hi David, I’m in the process of installing Windows ME on my old Dell Inspiron 8200 to start playing with the PC-Link and have come quite a long way: I’ve been able to download an image file for a Windows 98 bootable floppy with CDROM support, with which I’ve been able to format my harddrive and walk through the whole installation with the WinME CDROM until it needs to restart and the computer gets into an endless restart loop (start-up in Safe mode also fails and comes back with the same options). I’ve done a search on-line and it seems to be an issue that others have run into as well, but unfortunately all suggestions point towards no longer existing Microsoft support pages. Have you come across this as well and/or do you have any other suggestions?
Cheers Alex

As for as I know, it is a problem with the drivers for the computer’s hardware. Please correct me if I’m wrong.

ME has drivers for the hardware of that time on board, most notably drivers for the mainboard chipset. But when newer hardware, newer mainboards and thus newer chipsets are developed, after some generations of newer hardware (a few years) the old drivers that are present in ME will no longer function on those chipsets, and errors will occur. Those errors range from the inability to install windows at all, to some occasional blue screens or random lockups.

For instance, it is totally impossible to install windows 95 on todays hardware. The chipset drivers built into w95 don’t know how to handle todays hardware/chipsets.
Also that is the reason why they released W95 version 2 and later version 3. I don’t remember the exact name of the releases, sorry. W95 V3 had USB support, which was totally new at that time!

So back to your case. I have not researched it, but it could be that the Inspiron 8200 is too new for ME. ME was around in about 2000, released in 1999 if I remember correctly. So then you need older hardware.
Unfortunately, you can not grab W2000 and install that, because DCC Studio won’t run on W2000 I believe (has anyone tried?).

One possible solution to this is virtualization or emulation of ME, but that has it’s own hardware related challenges. I have succesfully installed DCC studio on a W98 installation on my modern PC using WINE (emulation), but I have not been able to test the cable link to my DCC175 for the simple reason that I have not got a cable. Probably the emulation layer won’t allow access to the parallel port directly, which is what DCC studio needs.

Another possible solution: you can also try virtualization, VMware, Virtualbox, KVM, Qemu or other products. Now, I have been able to run a virtual W7 installation that successfully could address a specific piece of hardware that required W7 drivers to access it. So direct access to hardware may be possible.
I have not tried a virtual PC that runs W98. As said, I haven’t got the 175-cable anyway.

This has to be further investigated by someone who has access to a cable.

-Philip.

Interesting points @pvdm. As far as we know, a virtual solution has been attempted by a few people.
None of them worked as the parallel port hardware with the DCC link cable would never be recognized or work in a stable way.

1 Like

Yes, I’m fully aware of the challenges with virtualization and hardware. :sweat_smile: :sweat_smile:

I am very curious about this entry in the man page of qemu however:

   -parallel dev
       Redirect the virtual parallel port to host device dev (same devices as the serial port). On Linux hosts, /dev/parportN can be used to use hardware devices connected on the corresponding host parallel port.

       This option can be used several times to simulate up to 3 parallel ports.

       Use "-parallel none" to disable all parallel ports.

Of course your host must have a physical parallel port. That will be a problem. I don’t have one, anymore.
Not sure if something like this

https://www.allekabels.nl/parallel-kabel/7106/1285998/usb-naar-parallel-kabel-1.5-meter.html?gclid=Cj0KCQiAyJOBBhDCARIsAJG2h5dVbcl7lxld49hMyK2ECum7KdQDZlLiUrg_WrlqHmb2shEaZ4J0ITAaAjDdEALw_wcB

would work. I’m afraid it will just add another layer of difficulty (read: problems).

Thanks for the engagement in the discussion and suggestions. Sounds like finding a still working Windows 98 computer might be the easiest way to get started. I’ll keep you guys posted!

I did not but, because it is NT-based this special direct hardware access sauce would not work. It is closer to Windows XP than to Windows 9X (95/98/ME).

Very true.

1 Like

I knew keeping old of all that out dated hardware would come in handy one day :laughing:
I have probably got 3 or 4 motherboard/cpu/ram set ups all with native parallel & serial ports.

2 Likes

(I split this off to a new topic because this is about Alex’ attempt to get DCC-175 software running on the Dell Inspiron 8200 and the previous posts were more about the software in general)

As far as I can tell, the Inspiron 8200 was released in 2013. I’m afraid that’s a little too new for the DCC software. There are no Windows 98 drivers available for the system from the Dell website, only Windows 2000 and Windows XP drivers and those Windows versions won’t work with the DCC software. You could try it of course, but if you can get Windows 98 or Me to run, it will use default drivers such as the standard VGA driver, and your Windows will be slow, and the DCC-Studio program will probably get buffer underruns all the time because the CPU is going to be too busy dealing with the hardware.

That (probably) won’t work. I have to admit, I haven’t tried it since probably 2005 but I expect that any emulation code for the parallel port is going to emulate it for printing, not for the specific use that the DCC-Studio software requires. I hope I’m wrong of course, but don’t get your hopes up.

No. it won’t work on Windows 2000 because the OS won’t let DCC-Studio access the port directly. That being said, there used to be a driver that allowed direct port access to user-mode applications. I can’t remember what its name was. And I doubt that it would make DCC-Studio work.

No, that won’t work. Programs for virtualization will emulate things such as a printer port and they can even virtualize a native COM port from a USB serial port, but as mentioned, DCC-Studio really needs direct access to the port to communicate with the PC-cable. The emulation, if it even works, would probably add too much latency. But the emulation is probably specialized in printing, not in anything else.

You will have to either find a laptop from 2001 or earlier with a physical printer port on board and drivers that support Windows 98, or build your own system from old hardware. It’s not impossible, people do this all the time to play old games.

I don’t know what @drdcc uses for his DCC-175 recording factory but I use a Dell Latitude CPi-300 from 1999. I owned it since it was new, from the time that The Netherlands had “PC Prive” projects where you could buy a computer through your employer from pre-tax salary. It’s a 300MHz Pentium II with (currently) 256MB RAM which is the maximum. A quick glance at eBay shows that those are available on eBay for a little over $100.

===Jac

1 Like

The Dell Inspiron does have a physical printer port, but I’m inclined to assume that - as Philip wrote - Windows ME is getting stuck because of the incompatibility/absence of drivers. I have an acquaintance who’s been in IT support for 20 years and he’ll have a last look at it, but frankly I think getting older hardware is probably the way to go. Here in Australia you can buy a 2nd hand tower for $100-150 and refurbished for around $300. Not too much of a layout.
On a positive note… before I wiped XP off the computer I plugged in the PC-link and it immediately came with a notification “Windows has identified new hardware Philips PC-link” or something similar. Reassuring to know that I at least didn’t buy an empty shell :slight_smile:

1 Like

Yes, the PC-link cable has a valid Plug-and-Play response. Unfortunately you can’t use it to install a device driver because Philips never made one. I don’t know enough to write a device driver (though I have some idea how the cable probably works now) but theoretically it would be possible to do that, and have it automatically install itself using Plug-and-Play. And yes, at least that tells you the cable is working.

If you get Windows 98 installed on your machine, you will probably want to configure the printer port to use ECP mode in the BIOS. My experience is that that works best.

===Jac

1 Like

Thanks Jac, for now we’re into a 5 day lock down, so not much will happen in the next few days, but I’ll keep the forum posted.

3 Likes

Just a bit of an update…
Today I picked up my Windows 98SE computer and so far so good: DCC-Studio and DCC2WAV are both running. I’ve already made a short test recording from DCC to HD and converted to WAV. Then ported the sample via USB stick to my Windows 10 computer and played the test recording. All very exciting stuff! As I’m writing, I’m uploading a complete album (RA from Utopia as it happens to be) and will try to convert to WAV (I gather from what I’ve read on this forum that you need patience with a capital P for DCC2WAV to do this, but frankly it doesn’t bother me too much…yet!) and see if I can get it to play on my A&K 70MkII.IMG_2639|666x500

)

3 Likes

Nice! Audio through the printer port! Now I’ve seen it all! :sweat_smile:

3 Likes

That is a full on retro looking PC, love it. You just need an enormous CRT monitor to complete the picture! :100:

1 Like

You can use MP2ENC to convert WAV to MP1 much faster, and then use DCCU to convert MP1 to MPP/TRK.

(I hope to integrate the two programs together one day with a friendly graphical user interface)

===Jac

I’ve been playing with the set up now for a few days and I have a couple of questions.
Is there any other documentation for DCC-Studio (and DCC2WAV) than the help files within the programs?
When I load the tracks from a DCC tape into DCC-Studio, the program is apparently recognizing the individual tracks (counter goes up in the footer line), but it doesn’t split the tracks in individual files. In other words, you must always by hand (be it with the help from markers) extract the individual tracks and copy/save them to a new file yourself, correct?
Loading music from DCC->Studio works very well for the A-side of the tape. I’m having a lot of trouble getting it to load the B-side of the tape. When the tape has arrived at the end of side A end it stops, I try to get onto side B by clicking the screen-start button again (as you would do on the 175 itself), but most of the times it briefly starts and goes back to stop. Occasionally it sets off a frenzy of A-B side switches and if you keep trying long enough eventually it’ll keep running on the B-side (and you can start to record the tracks into Studio). Am I doing a something wrong or is it simply a bit temperamental?
Another question: when I play back Studio files, the audio is being passed back to the audio connections of the player. If I use the headphones connection, it sounds very weird, as if there is a phase shift between the channels and starts to sound like a concert hall with lots of echo. If I use the line-out connection, it seems to sound alright.
Apart from the points above I have to say that conversion from .TRK to .WAV via DCC2WAV is working a lot better than I feared. Conversion time on my computer (AMD Athleon 1700+ / 1.47 GHz / 512Mb RAM) is approximately double the real time length of a track, i.e. 5 min track takes appr 10 minutes to convert. When I play it back on my Windows 10 computer it sounds very good (as far as can be judged by playing on the computer). In the next few days I’ll try to get it onto the Astell&Kern, which will be the real test (I have no reason to assume anything else than it being perfect though).

Hi,

The behavior you are describing for copying a pre-recorded tape is normal. It will show all the track info, but does not separate any tracks. Just one big track for side A and B. If you copy the tape back, that information will not be copied.

If you have setup the tracks on Side A and B correctly, there might be something wrong with the tape or player as it should automatically switch to side B. Try shorten side A to see if that helps.

The audio problem with the headset can be caused by using a 3 ring connector headset (so with microphone), like you use for cell phones. The portables will sound indeed weird. Only 2 ring connectors will work decently as far as I know.

1 Like

The book that came with the DCC cable (or was it the recorder?) explained how the software worked. It’s pretty well-written if I remember correctly. In Dutch of course. I haven’t looked at it for a while. I suppose we should scan it some day.

It would be awesome if DCC-Studio would automatically split up files or assign labels, based on markers on the tape. Unfortunately it can’t do this although I would think the engineers probably wanted to do this (as you say, it does pop up a window with all the information during the recording). I guess they just ran out of time.

It also doesn’t record markers based on the markers in a file. The only way to record markers is to split a track into multiple TRK files, and give each of them a name, then make a compilation tape. I have some ideas on doing this automatically in my future DCCE tool but I’m focusing on hardware reverse-engineering right now.

This sounds like a mechanical problem of the recorder. It’s definitely not a software problem.

That means the ground connection of your headphones is not connected. You’re hearing the difference between the left and right channel so everything that’s in the middle is gone. As Ralf said, it may be caused by plugging a headset with a microphone into the recorder. If you plug the wired remote control into the recorder, and plug the headset into the wired remote, that might fix it. Also try different headphones, preferably a pair without microphone. Or plug in a splitter that lets you connect 2 headphones. Or anything that has 3 rings on the connector instead of 4, really.

Ha, you have one of those super fast Gigahertz-plus computers LOL.
On my Pentium at 150MHz it took a whole night to convert a WAV to TRK/MPP in 1995. I only did it once.

Seriously: DCC2WAV is annoyingly slow, for both TRK->WAV as well as WAV->TRK. It’s better to use the “save as single audio track” option (I’m not sure what the name is but I think it’s in file manager), and then use my DCCU program to convert the MPP to MP1. Then you can use any audio converter to convert it to something else, or use an audio editor such as WavePad to edit the audio. WavePad can load the MP1 file without conversion to WAV. (*)

Vice versa, you can also use DCCU to convert an MP1 to MPP/LVL/TRK (the LVL will be empty because I haven’t figured out how to generate VU levels yet). And you can use MP2ENC to convert WAV to MP1. See links in a previous post.

MP2ENC is much faster than DCC2WAV, I think on my 300MHz Pentium 2 laptop it works faster than real-time. On my Windows 10 system it converts the files almost instantly.

===Jac

(*) At the time of this writing, there is a bug in the WavePad MP1 encoder (and also other MP1 encoders by NCH Software) which makes it skip the first frame of the MP1 file. I reported this as a bug months ago, but haven’t heard from them.