DCC 600 no cassette/ cassette blocked

Hello everyone,

I bought a DCC600 with some problems as a winter project. The device gives 2 messages. 1 Sometimes “cassette blocked” and sometimes 2 “no cassette”. I think based on the display messages that it is a sensor error. Before disassembling the device for cleaning, I would like to know your thoughts on the problem and the possible solution (s). The tray opens and sometimes eject the tape with a cassette blocked display message and sometimes it closes then stops with the no cassette displaymessage.

Here is a video about the dcc 600. https://1drv.ms/v/s!Ait1qTScTRHmoINRfwMxbDZ6sMwRWw?e=mGREq5

I tried cleaning the switches as seen on the picture that Ralf suggested in another post. That did not help. I have put the player in Service mode and when i tested the open and close operation it displays “Tray open OK” and “Tray Close OK”

Hi Jos and Welcome,

3 areas need checking (circled in Red from your video).

Try manually help the cassette go down by:

  • spinning the wheel (red circle left)
  • pressing the red circle in the middle
  • Pressing and checking the switch (red circle on the right).

Ralf

/

1 Like

Thanks Ralf for your swift reply. I have tried your suggestions. There was no difference. I typed some more findings in the original message like the going trough the service mode. When I insert the dcc there is a short(1 second) spining sound. Then everything stops. And the controls dont react.

Did you check the belt and gear?

1 Like

Thanks for your reply Ralf,

No, not yet. I was hoping to avoid that part. But I will take my plunge and study your youtube posts this week on how to take the mechanism apart. I will check the belts and gear and post my findings here.

PS: It is nice to see that people have a passion about this technology and help out each other.

2 Likes

Hi Jos, welcome to the forums.

I have a DCC600 with the exact same problem. I haven’t had a chance to take a good look at it yet (it’s a smelly machine from a smoker’s house and the heads are broken so it will likely be a spare parts machine so it’s not the highest priority right now). I think one or more of the sensing switches in the cassette compartment is dirty or not working. Try putting the recorder in service mode and go to the switch test, then push the switches with your fingers to see which ones aren’t working.

I noticed your display is not very bright either. That’s probably a power supply problem but most likely not related to not detecting the cassette. Let’s sort out the other problems first.

===Jac

1 Like

Thanks for your reply Jac,

I have put the device in Service mode and tried to test the switches. Only Tray opens en close OK. The rest of the switsches dont not seem to react.

I made the video in bright daylight. Thats is likey the cause of the dim display.

You are right. Lets solve the basic problems first.

Thanks for helping me out.

After watching the youtube video about the gear change about 10 times, I felt comfortable enough to have a go at repairing the device. I have disasembled the dcc 600 and noticed that somebody tried to repair the device in the past. I noticed that the front screw was missing and found it later on when I lifted the tray mechanism out of the chasis.

Findings
1 The clog did not seem broken.

2 The main belt was way to loose.

3 The pinchrollers seems to be fine

4 The head looks fine.

When I turned the mechanism upside down this felt out:

I cant seem to find a sensor that this lever should be triggering. (is that right?)

Any advice what to do next?
I guess changing the belts, clog and pinchrollers?

Jos van der Kolk

Hi,
The links do not seem to work.

Ralf

For me neither. @Jos_van_der_Kolk You should be able to upload all of them directly to the forum by dragging them into the editor or using the upload icon in the menubar of the editor.

Sorry about that. I have adjusted the links.

Jos

Perfect :+1:!

I believe this is the part mentioned in the video when you start mounting the mechanism back together.

The lever shown at 9.00 Might be broken.

1 Like

Thank you for your illuminating photo Ralf. I’ve tried on the part you point to in the picture, but it won’t stay put. I assume it is broken. Can the DCC museum provide me with the necessary replacement parts? The device is open, so I might as well replace all maintenance-sensitive parts?

Hi Jac,

Have you already got around to taking your smelly machine apart and use it as a donor machine? I need a head for my DCC 600. The museum has no spare heads left, and a donor machine is not available.

1 Like

I haven’t had the time, but it wouldn’t do you any good: one of the flex cables got torn off the head during disassembly…

===Jac

Thanks for the reply Jac. :+1:

Hello to all.
I have the same problem on a DCC 300, that I resolved changing the drawer belt; but now I have another problem, the deck don’t play the tape, it switches from play to stop, side A and side B, then stops. I suppose that I must change the motor belt, the one that pilots the two capstan, even if it looks in good condition. Well, in the DCC 300 there’s a little difference from the mechanic in your video; it has a fixed cable from the infrared receiver and mechanic, which appears to be welded on one side to the receiver, on the other side to the board connected to the front; since I can’t easily remove the mechanics and I’m afraid of breaking the two plastic blocks that hold the capstans in place, I ask you: can I remove the card that is attached to the mechanics, at least to access the two plastic blocks more easily? Another small favor: since in the movie it is not clear how to unlock the two plastic black clips, can you help me with clearer photos? Thanks!!!
P.S. How can I attach some photos? Thanks

If I remember correctly, the DCC 300 and DCC 380 have an extra screw behind the front panel display window. You have to pry the transparent plastic window off to access it. And you have to unlatch a little piece of plastic that looks like it was made to break and void your warranty. Please study the service manual carefully. You will need the service manuals for both the dcc300 and the dcc600.

=== Jac

Thank you Jac. I have some little news… I verified that the recorder works correctly, yesterday it reproduced the DCC perfectly in both directions. I had problems loading and unloading the tape, so I disassembled the mechanics and replaced the belt that controls the opening of the drawer. Today it perfectly recognizes both ACC and DCC but … it doesn’t reproduce them anymore! Inserting a DCC and pressing play, it goes to stop after a couple of seconds; the tape comes out, near capstan, for about one cm. Also, it does not fast-forward and rewind the tape, either with ACC or DCC. What may have happened? Thanks!