Technics RS-DC10 "CASS BLOCKED" error

Good day to every DCC enthusiast. Unfortunately I wwill start my journey here with a problem…
Last evening I was listening to a DCC tape, all was ok. I wanted to change the tape, abut after I inserted the new one, no mechanism sound and the drawer was ejected with the CASS BLOCKED error message. I tried several times, nothing. A normal cassette works perfectly.
I opened it (again, after 1.5y since recap), found a ground wire broken, fixed it, nothing. The cassette slider does not slide and the tape does not sit normally in its position. I made some photos, I will try and upload them.
Thank you in advance for any idea.

Hi and welcome to the forum.
I believe the part I circled might be broken. The plastic sometimes fails. You can remove it and check it by simply remove one screw.

This part opens the dcc so the tape can reach the head.

1 Like

Thanks a lot for the advice, tomorrow I will open it again. I really hope to fix it :slightly_smiling_face:

1 Like

Sorry for a very late reply (due to personal problems). I managed to open it today again and… It seems to me the plastic part is broken… And maybe some pin is missing from that hole?

We have them available for patrons of the dcc museum from a spare part museum.

You can contact me at [email protected]

Back again, and again after a long time… Until I will be able to buy the part, I tried at first to replace the missing pin. I tried with a nail cut to an approximate size I saw in some photos, and it worked several times. Unfortunately couldn’t take a video before the plastic “beak” broke forever… Now I did it the “engineer” way :grinning: Meaning there is nothing ductape cannot fix, right? So I apply a square of ductape that retains the metal cover open, and all works well :grinning: