Philips DCC 600 repair

Hello,
Recently I bought a used Philips DCC 600 from a thrift store in order to play some cassettes I own. When I got home I plugged it in, inserted a cassette and found that the door opens and closes fine. It’s only when I play the tape that I run into a problem. It is almost as if the sound pulses. I have opened it up and found that the belts are fine, I saw no leaky capacitors etc. the only thing is that the read/write head does not engage, the rest seems to work fine. I have looked at a number of Dr. DCC’s videos and haven’t found a solution to my problem, my search has lead me to this forum. I have gone through all of the steps in this video: https://www.youtube.com/watch?v=sfLjp3ah19E&t=312s.
Does anyone have an idea of what the issue is and how I can resolve it?
Thanks!

Welcome to the forum!

Capacitors should rarely be a problem with a DCC 600.

You say the head doesn’t engage, so if that means what I think it means, you’ll have to check the mechanism. Probably you have to clean off the old grease (it was originally white but probably changed to brown and turned into chewing gum). There’s a small chance you have to get a new idler gear from the DCC museum.

You say the sound “pulses”. First of all, if the head doesn’t engage, you should have no sound at all; if you hear a pulsing sound anyway, it’s some kind of interference.

If you can, once you get the head to engage, try to play an analog tape. Do you hear excessive wow and/or flutter? Do you hear anything at all?

If you don’t feel comfortable doing mechanical/electronic repairs, contact the DCC museum.

=== Jac

1 Like

Okay, so here’s an update.


On the side of the cassette compartment there is a PCB with these two flat flex cables on it, when the play head is manually engaged and they are both plugged in you hear the thumping pulsing sound. When only the right cable is plugged in you hear the contents of the analog tape but it is very heavily distorted by an excessive amount of wow and flutter. When only the left cable is plugged in you cannot hear anything. When the playhead is disengaged the pulsing sound remains audible but when either of the two cables is disconnected it becomes silent. Between every try I have disconnected the mains in order to (I hope) prevent any damage to the system.

I have noticed that the motor the capstan belt is attached to never moves, or atleast, I have never seen it moving, so that could be a pcb issue or the motor could just be dead.

I have opened the cassette compartment up further but haven’t found anything weird, everything looks like it does in this video: https://www.youtube.com/watch?v=OmM2mbbz7F4. The gear being replaced in this video looks as good as new.
Any ideas to what the problem is?
Feel free to ask further questions, I will probably open it up again soon anyways.

The two flex cables are the cables to the heads. Be careful; they are very sensitive to static discharge while they’re disconnected. The service manual suggests that you put a paper clip over the contacts immediately to prevent damage.

When you put a DCC cassette in the recorder, does the display show the DCC logo? If not, the problem is that the recorder is not properly detecting that it’s a DCC cassette. It plays the cassette as an analog cassette and all you will hear is hissing and rattling (about 5 or 6 rattles per second I think).

It’s possible that the DCC detection switch is oxidized or dirty, which could cause this problem.

=== Jac

Thanks for the advice on the flex cables!

Since I’m kinda new to the format I don’t own any dcc tapes yet, I’m going to have to order some, I can’t test any out just yet.
If the problem were the dcc detection switch, it would be an easy fix, right?
Would that stop the weird wow and flutter issue and the pulsing sound though?

If you only have analog tapes, then the above is not applicable :slight_smile:

If there is a problem with the detection switch, it’s probably easy to solve.

Any wow&flutter you hear on analog tapes probably are caused by mechanical problems, most likely the deck needs to be taken apart, grease removed and replaced, a new belt and possibly a tiny drop of oil in the capstan bearings.

Because of age, you will likely have wow and flutter problems with any DCC recorder today. They used to be good analog cassette players but not anymore, simply because of age. Wow and flutter on analog tapes are a good indication of how well your mechanism works, though; if you try to play a DCC tape in a recorder that can’t keep its own speed constant, it won’t play.

If you have any more questions, feel free to ask. I recommend recording a short video of what the problem is. Also if you can, let us know exactly what you are trying and have tried, and what went well and what didn’t.

The service manuals are at https://digitalcompactcassette.github.io/Documentation/Service%20Manuals/ . If you don’t understand something from the service manual and don’t know anyone who can help you, please don’t just try things out but ask in the forum. The electronics in a DCC recorder can usually be repaired, but there are also a few parts in every DCC recorder that are easy to break and cannot be replaced (such as the head) unless you have another recorder that can be used as parts donor. If you get in trouble during a repair, it’s still possible that the DCC museum can help, so stop right away and ask, before it’s too late.

We should put these tips in a sticky post, by the way…

===Jac

PS another thing when you ask a question: give us some idea of what your talents are. The instructions we give to a beginner are going to be different from the instructions we give to someone who has repaired digital electronics all their lives.

Hallo, ik had hetzelfde probleem met de DCC 380 dat de kop niet bewoog.
Nu bleek dat de riem van de capstan eraf lag.
Riem er opnieuw omgelegd en de kop werkt weer alleen een gewone compact cassette laat het display zien no cassette.

Hi @Giant1972 Welcome.

So the head not moving was caused by the capstan belt not being in place? I repeat the message in English, as this is mostly international.

The No Cassette message could be the tray belt or the detection switch on the mechanism. It is on the far right hand side and on the back, looking from the front. Gently press it to see if it makes any difference.

1 Like