Philips DCC 600 - "No Cassette"

Hi folks,

due to the fact that my the cassette tray of my Philips DCC 600 did not open properl, i have ordered and changed new belts. After that I put a DCC cassette in it and closed the tray “no cassette” occurred in the display.

I have already checked the two rows of switches a row of 4 and a row of 2 - cleaned them with contact cleaner and they are working fine if I press each of them via continuity tester.

Do you have a tip for me?
Where can I found a switch or something like that, which tells that a tape has been inserted?

Many thanks in advance for your support.

Cheers

Chris from Krefeld/Germany

Hi Catweazle, welcome to the forum.

You might want to get the service manual and put the recorder in service mode (without cassette inserted) and use the “hole test” to check if the microcontroller sees that the switches in the cassette compartment are closing when you operate them by hand. You say you tested the switches for continuity with a multimeter; if they check okay and the service mode program is not “seeing” them, check if there is a problem with the wiring (check if the signal from the switch makes it all the way to the microcontroller). If the microcontroller is getting the signal from the switch (measured with a volt meter) but it’s saying it doesn’t, it unfortunately means your microcontroller is broken. But that’s VERY unlikely. Probably your problem is simply a switch that you overlooked when you did your continuity testing, or a loose cable.

EDIT: to get to HOLE TEST mode on the DCC600, power the machine on without a cassette, and push and hold REC/PAUSE and DOLBY while pushing PLAY. It should say “SERVMODE Vxx” (where xx is a number). Then push NEXT; now it should say SERVICE MODE. Then push RECORD to put it in HOLE TEST mode. Every switch you push in the cassette compartment should show up as “HOLE X OK” if I understand correctly.

It looks like the “CASSETTE IN” switch is part 1705 on page 63 of the service manual.

===Jac

Hi,
We have seen this problem a few times.
Did you check these Switches? They are most likely dirty, broken or misaligned.

Ralf

These switches are working fine in case the tray is open/close.

Any other tip?

Have you checked service mode to see if the microcontroller agrees with you that they work? See my previous post.

===Jac

1 Like

I am a little bit lost!
I entered the Service Mode - Then push NEXT; now it should say SERVICE MODE. Then push RECORD (REC / MUTE!?) but this button did not work, because “HOLE TEST” didn’t appear. I pressed the REC / MUTE button serveral times - no reaction!
When I press “APPEND” -> TRAY TEST" appeared.

Any idea?

Sorry I don’t have a DCC600 handy (it’s packed up in the garage). I wrote that from the flowchart on page 25 of the DCC600 service manual.

===Jac

2 posts were split to a new topic: DCC600 Tape Blocked

Update - the fault is somewhere in the tape unit / device, because I put it in another case inkl. circuit board with the same error result.

And also there the push RECORD (REC / MUTE!?) but this button did not work, because “HOLE TEST” didn’t appear! -> maybe this is another topic.

Issue can be closed.

I can’t just narrow down the cause of the error. I had another defective DCC 600 with defective mechanics in the slot. Then I only installed the drive unit (with all the microswitches) into the actual defective one. I continued to use the slot and the tape head unit. I found that the gear was broken and this one. I’ve now ordered a new one, because the other one is already a bit chipped.

It’s just running again! :slight_smile:

1 Like

Nevertheless, the service mode “Hole Test” does not work as described for the DCC 600 - neither of my two devices!

2 Likes

Thanks! Good to know. It’s not unusual to have bugs in the service mode; obviously it’s not the most important part of the software so it doesn’t usually get tested before the factory starts making preprogrammed microcontrollers.

Next time I have one of my 2nd gen recorders out, I might investigate what’s going on, and if there is a workaround.

===Jac

Hello,

I’m new here because my DCC600 has the same problem.
I did the servicemode tests and it passed all hole tests and tray test ok.
At last I found out that there is another sensor in the red1 mechanism that checks if there is a tape inserted. The signal goes from the red1 to the mainboard an from the mb to the front board and it ends at pin 10 of the processor. It should be 0 volt if a tape is inserted but mine is 5 Volt. So the proc. says “no cassette”.
Thought of grounding the signal by hand, but this is a hack I only will do as last option.
First I will remove the mechanism and take it apart to find the broken switch.

Any hints how to take it apart and put it togehter again?

Forgot to say: The service manual has many errors, as wrong numbered pins and connectors and so on. Even the way how to do the service mode tests are wrong. For example: mark erase for key test, but it really is mark write.

Greetings
Ralf

1 Like

Hi @Bandsalat and welcome.
It might be that the switch is dirty as well.

Here is a video on how the take the mechanism apart. Hope it helps.

Hello,

no, the hole-switches are working. I tested them manually with the multimeter. And I checked if the signal arrives the processor correct. All OK except the cass in1 signal and the corresponding switch is in the red1 mechanism.
I’ll take a look at the video tomorrow.

Greetings
Ralf

Could you give us an update?

Hi, I’m having problems with the ‘no cassette’ message. Could you tell me where the switch is in the red1 mech? Thanks

Hello,

until now I had no time to disassemble it. It’s still waiting for repair.

Did you check the hole-switches by firmware testmode? Is it the same problem as mine, cassette is inserted and pin 10 at the proc ist 5v?

Greetings, Ralf