DCC600 Boot up issues, strange work around and some smoke please help me!

Hi All. Just bought a DCC600 which would not turn on. This was a simple fix involving an open circuit track near the voltage selector switch on the supply board. So now the front panel lights up saying “no cassette” but the open/close button does not work. Entered the service menu. All the tests work except the ones that involve comms between the main micro and the front micro (such as get SW version). Once one of these has been entered the front micro hangs. This turned out to be where the I2C bus would not get beyond the start bit (SDA goes low and stays low so now the front micro is in limbo). OK so the main micro must be faulty and not booting up. Checked all the control lines, power supplies, clock signals around the main micro - all present and correct. Disconnected the Flat Flexible Cable which connects the digital board to the read/write board. Hey presto the main micro will now boot up* and communicate with the front micro via I2C. Open/close works and the draw opens. All the sevice mode tests work and pass including the L bus tests. *However this state of affairs will only occur ocassionally. Most of the time when powered on the main micro still hangs - what you need to do is turn on, then off and on very quickly (referred to as “the technique”). You will hear the tape motor pulse and then you know the micro has booted. So maybe its a boot up sequence timing issue. Scoped out the SRES, microP, HRES and RES (front micro reset) lines on my 4 channel Tektronix and they conform to the boot sequence in the service manual including when the main micro resets all the digital board chips. The timings remain unaltered between the times when the main micro will boot (with the technique) and when it won’t - weird. I tried altering the value of 3419 (part of RC network on front micro reset pins) with a pot to no avail. Also when the read/write board FFC is plugged back in, the micro resolutely hangs even when using the technique. What happens here is when the main micro pulses the DCCRESET pin to reset all the chips on the digital board this line starts to oscillate with a square wave signal that persists even if the FFC is unplugged again - so the main micro has entered a weird state and hangs. If you plug the read/write board in after booting using the technique everything is OK and it will play an analog cassette. At least I think it will - while I was mending the cassette detect switch, which was dislodged, I accidentally shorted out the 30V supply rail to ground when the draw, which was disconnected from the cassette mechanism, activated like a trombone and pushed the main board onto a metal ruler and that part of the supply board fried, so I’m awaiting parts to fix that.

While I’m waiting for parts, any ideas on the fundamental front micro/main micro boot up comms issue and why the read/write board has such a profound effect on the main micro DCC RESET pin when all it adds to the circuit is the RDMUX line - which is inactive. Right now, in order to use this I would have to take the lid off, unplug the read/write FFC, do the technique, plug the FFC back in again, replace the lid and insert a cassette!!

Anyone who has solved a similar issue your help would be gratefully received.

PS I have a cap tester and they are all fine! Once booted, the unit will go into stby usng the IR code but again the main micro hangs coming out of stby. All the supply lines etc remain up during stby so that rules out any supply voltage glitches during turn on I think.

Well, I have the answer! The reason the main micro would hang was that the transistor which controls the LTCLK input to the ADAS chip had gone open circuit. This meant that at some point the main micro did not receive an acknowledge and so stopped at this point in the boot up sequence. Quite why the “technique” fooled it into getting past this point I can’t say. Anyway the unit is fully operational now and plays analog tapes very nicely. Just waiting for some blank DCCs to arrive so I can test the digital side. Oh and the read/write board issue turned out to be a short to ground on the DMUTE trace caused by a solder blob. Wonder how long it had been like this? The unit doesn’t seem to have seen many miles…perhaps it went faulty from new?


Some serious solving skills. Thanks for sharing and welcome to he forum.
What is your location?

Hi drdcc and thanks! Sadly this unit turned out to be beyond repair as it will play back DCC tapes but won’t record them. On playback there are zero errors reported in service mode which is good. In record mode there is WDATA and WCLK getting to the write amplifier and the TDA1316 is outputting the correct signals. Also it will erase a previous recording. I tried trimming the write current but to no avail. In the end I measured the resistances across the write coils in the head and 4 and 5 are open circuit so of course it won’t record anything. Unless I can get a new head from somewhere this is a playback only machine unfortunately.

I should just add in case it helps anyone that the faulty transistor on the LTCLK line was #7521 and yet another problem I mended on this unit was a VU meter indication which would not go beyond -30 dB caused by a faulty op-amp (7411) on the front board.