Dcc300 does not play DCC cassettes only ACC

Recently I got my old DCC300 back which my father had kept in his equipment collection. Alas he passed away last month so we are now going through all things he kept. The recorder still looks in good condition but refuses to play DCC cassettes and the drawer misbehaves sometimes. Old analog cassettes play ok(ISH) but none of the DCC cassettes (pre recorded or self recorded) do. Could this be a belt problem ?

Hi, and welcome to the forum. Thank you for sharing your story.

The belt needs replacing for sure, but might not solve the problem.
The head needs to be cleaned as well (Isopropyl Alcohol).

If you then put in a dcc tape, does the display show the “dcc” logo in the display?

Hi Ralf,
Yes the DCC logo appears on the display, and when pressing play the tape often starts but without audio and no titles etc. Sometimes it starts (re)winding after inserting a DCC tape and then keys becomes unresponsive untile either end of the tape is encountered, you can then press play and it will display READING and stops after a few seconds. Trying the wind/rewind button only changes the display but the tape does not run then anymore. Eject still works and when reinserting the tape the whole story repeats :-). It looks like it does not read digital data from the tape,
I will try to clean the heads (again).

Hi Gert,
If the dcc logo is “on” the switches have detected the right tape (DCC),
The news might not be good, because in my opinion there might be problem with the head.

It can’t read the TOC and that it is why it is acting so strange.

If that is the case, there is not much that can be done, other than find a donor to fix this.
It is a very rare situation, but I have seen it before.
The second generation players, are sturdy with only problematic gears and belts. If the head is affected it often means that someone could have tried to demagentize the head, but that is speculating in your case.


1 Like

Hold on, not so fast…

If the recorder plays analog tapes but not DCC’s, it may just be that the head is dirty.

While there is a cassette in the recorder (preferably one that’s not a prerecorded cassette but does have something recorded on it) and the recorder is powered on and in STOP mode, hold both the DOLBY and REC PAUSE button while pressing PLAY. This makes the recorder go into service mode. Then use the PLAY button to start playing the tape. You should see some numbers on the screen like “z xx yy ffff” where z is the selected head, xx and yy are the error rates for head z and head z+1, and ffff is the number of frames on tape that didn’t have any errors on it. Use the TIME button to switch from head 0 (and 1) to head 2 (and 3), 4 (and 5), 6 (and 7), and 8 (auxiliary track).

Normally the xx and yy numbers should be 00, or may count up to a low number sometimes for some of the heads. The ffff number normally counts up at about 5 frames per second; it’s normal for it to reset on a regular basis except maybe on a brand new, perfect tape. If your head is entirely broken, you will see high xx and yy numbers for all heads, but if it only shows high xx and yy numbers for a few heads, there may be hope that you can clean the head with some isopropyl alcohol and that it will play fine again.

For more information about service mode, see page 25 of the service manual at https://digitalcompactcassette.github.io/Documentation/Service%20Manuals/philips_dcc600.pdf (This is the DCC-600 service manual; we don’t have a full service manual specifically for the DCC-300 but apart from the front panel, the DCC-300 is pretty much identical to the DCC-600).

To elaborate on what Ralf said: If a second-generation recorder tries to play a prerecorded tape but there is not Table of Content on the Auxiliary track or it can’t read the Aux track, it will start searching the entire tape to find another copy of the TOC. Only 2nd-generation recorders do this. You would also see this symptom if you put a user tape in the recorder and it wrongly detects that it’s a prerecorded tape. If the head is defective and the recorder correctly detects a user tape, it won’t go into search mode; it will simply think that it’s playing virgin tape. If the head is dirty or partially defective, it won’t be able to reconstruct the data from the missing tracks so it will just play silence. If you try to play a cassette that has the sticky-pad symptom, it will also not be able to reconstruct the music.

In other words: Your recorder is 27 years old, but it may still be possible to revive it. Don’t give up too quickly; if it plays analog tapes, it’s a good start! If there’s a lot of wow and flutter when playing analog tapes, it’s probably a mechanical problem.


Thanks for the answers but I made some progress!
After initially cleaning the heads with IPA and not getting results I dared to try my stylus cleaner fluid for the record player…
And… it is alive again! DCC tapes are playing again, alas I noticed some minor hickups now and then which might be due to the worn main belt or just tape degradation over so many years. I tried five DCC tapes and each was recognized fine again. Both sides of the tape work ok, so the head turning seems to work ok too. And it still sounds really good.

Is there a ‘belt kit’ available? I also read something about a gear which might become brittle/degraded?


1 Like

Excellent news!

The DCC museum can help with belts and a replacement gear.


Wow, Stylus cleaner. Never heard of that solution… lol other than for a stylus.
The heads can get dirty over time if not cleaned and then stored. I am glad you got it working again.

We have the parts and you can write us at [email protected] to receive more information about them.