DCC175 link cable issues

Hello,

I have a DCC175 with a DCC-LINK cable. I installed the software on a clean windows 98SE laptop with a LPT port as out/input. When starting the DCC studio software the player also goes on (so there is some kind of communication) but after that I get a error that the software cant connect to the device. I looked at the problem guide in dcc-studio and checked some things like the IRQ option that has to be enabled, port numbers etcetera. Under device manager the DCC cable is also visible. Has anyone experience with this issue?

Greets Tom

I have not seen this issue before.
Is the OS a fresh/new install?

Yeah Its a fresh install. I tried another dcc-175 player and having the same issue. So or its the laptop or the cable…

Try switching the parallel port mode between normal, ECP and EPP. My experience is that ECP works the best but your results may vary depending on the hardware.

Also if possible, try another computer.

===Jac

2 Likes

I can test the cable for you as well, if needed.

Jac,

Thank you very much for your help! Changing it to ECP mode in the bios solved the problem and everything functions as it should be. Again thank you very much and keep up the great work!

Greets Tom

4 Likes

Ralf,

Thank you very much for the offer but the solution of Jac solved the problem, I am glad the set I have I working as it should be now. Also for you, keep up the great work! :ok_hand:t2:

3 Likes

I had similar issue, but in my case, i have to change from ECP to EPP in BIOS setup to get DCC-Link cable working properly with my DCC175.

1 Like