DCC 951 - Dead head?

I bought a DCC 951 - the seller told me that it has a “Clean head” message. But he said that the player works (I can´t check it, if this is right). I received the player a few days later and it was not well packed. The mains connector was loose - i fixed it and I tried the player and I see the titel numer, time etc but no sound (the level is - 95db). I changed the belt and the pinch rollers but nothing changed. Analog tapes are ok and there is not a very high wow and flutter.

So I checked the Service mode and found that the channel 7 and channel 8 have errors 20 (100% errors) and chanel 9 has 10 to 13 (changing).

I tried to record and played it on an other DCC - no sound (but the recorder ereased the old content - so it was silent).

Caps look ok and as far as I could test it (as they are in the board), they are ok.

Unfortunately, I have a lot of portable DCC but no DCC from the 3rd generation, so I could swap boards.

So I think the head is faulty.

In the afternoon I tried to heat up the head a little bit (not too hot) with a hot air gun and the head came back to life - but for just a new seconds. I tried it a few times and everytime the same scenario (a few seconds clear sound , then drops and than silence). I have seen on the flatband cable two lines that where dark. I think this is the problem.

How much channels does the player need for playing fine? I have a DCC 900 and there is faulty channel and it plays very good.

Does anyone have an idea?

Thank you

A DCC player can reconstruct the audio if 7 out of 8 channels are working flawlessly and one track is bad, continuously. However of course if one track is consistently not working at all, any dropouts or minor problems on any of the other channels makes the player mute the sound because there’s just not enough data to reproduce it.

It sounds like most of your recorder is working and you already changed the belt and pinch rollers to eliminate some other possible problems. You may want to try to clean the head really well with a Q-tip (cotton swab) and some isopropyl alcohol. Sometimes a small persistent piece of dirt can get lodged on the head and block the tape from touching the head. Rub the head up and down (not left to right), and don’t be afraid to be rigorous: The head is somewhat fragile but a Q-tip with alcohol probably won’t damage it if you don’t go crazy. If you can, use a microscope or a magnifying glass to inspect the head and make sure it’s clean.

If the problem really is that there’s no signal at all on some of the pins of the flex cable, it may be necessary to fix that problem somehow. Maybe there’s a problem with the connector on the read/write amplifier board. That would be easy to repair.

In the worst possible case, your head may be defective. Maybe the DCC Museum can help with a replacement or maybe you can get your hands on yet another DCC recorder…

===Jac

Thanky you for the answers!