DCC 900 Playback Works but No Recording

Hi, I’ve got a Philips DCC 900 that I bought on eBay in non-working condition. I opened it up and sure enough the surface mount capacitors were leaking on both boards. I removed the old capacitors with a hot air rework station and then cleaned the boards with isopropyl alcohol. I replaced these capacitors and reassembled the unit. At first everything seemed to be working fine, it played back both DCC and analog tapes without any dropouts. However when I recorded something on a tape and then tried to play it back it was mostly dropouts. It is clearly a problem with the recording because other tapes play fine. The pinch rollers seemed to be fine to me, I didn’t hear any wow & flutter on analog playback. I also cleaned the head with alcohol. Has anyone had a similar problem? This is my first DCC deck and the tapes I bought are 90min Philips tapes that had been previously recorded on by the seller. I also tried erasing the tape with a bulk tape eraser but that did not fix my problem. Any help is greatly appreciated!

Hi and welcome,

It could still be the tape. Alternatively, a bad connection with the new capacitors
, bad side A-B connection on the board and worse case a bad head.

Clean the felt pad of the tape with IPA to make sure it is ok. Try this with at least 2-3 tapes to potentially exclude the tapes.


1 Like

My DCC 900 did not seem to record either, although the VU meters seemed to indicate it was recording. It turned out that it was the stick slip effect tape problem with my Philips tapes. It was recording, but did not play back because of this. Cleaning the felt pad did only help for a very short time. After replacing the felt pad all recordings played back fine.


I’ve got a more baffling issue with a 951. It too plays back fine, but although it goes through the recording process, not only does it not put anything onto the tape but the original recordings are still there to playback. I would love to know the issue with this.

Somehow this vagely sound familiar, there are a few black switches that can become dirty in the DCC900. Maybe the DCC 951 has them also? I think one switch is to detect if the cassette is recordable protected or not. try cleaning all switches with contact cleaner spray if you have them inside the 951. I had to do this also because my DCC track names where not appearing. DR DCC made an excellent video about it: https://youtu.be/XqsJ_C3ZWPY

That is very interesting. It means it will not even try to write, as their is no erase head. It simply overwrites the old data. Never seen this before. It might indeed be dirty switches.

I’ve got this issue two or three times with DCC900. It was due to interrupted control signal to the write IC TDA1316. Check the voltages or better waveforms on WCLOCK and WDATA. Generally check all the voltages on the chip. I’ve found very helpful to use services manual from Technics RS-DC10 as it contains all the voltages for every pin of the chip.


Put the dcc900 in service mode and check if the fault is the same on all tapes, if it is it might be the head, if it is intermittent than it is probably the tape or the feltpads…

If the recorder can write (at least somewhat) to blank tapes but not tapes that have already been recorded, the write current may need to be adjusted.



It is interesting, but what was the culprit with these units finally, what made the control signal interrupted? Looks like my DCC900 has the same problem, it does everything as normal when i record with it, also makes marker writing, but nothing is recorded and the previous music material is present without a glitch.