DCC 730 only plays analog tapes. Leaky capacitors the culprit?


I’ve a 730 that didn’t play dcc tapes when bought. I did change both belts and pinchrollers but to no avail. It has been sitting in a wardrobe since but I took it out today to inspect it more thoroughly and noticed that it has some leakage under three of the capacitors. I’ve read that this could be some sort of glue and is not leakage, but this defenitely looks like leakage to me.
Maybe someone can confirm this and if that could be the reason for not playing dcc tapes but only analog.
And what does those three capacitors connect to/control?


My 730’s have the same goo around the electrolytics.

I can confirm that this is not leakage from the capacitors, but glue to hold them in place. However, I understand that this kind of glue may gradually start conducting electricity over the years. So it’s probably a good idea to clean it off either way, and it doesn’t hurt to replace the caps while you’re at it.

That said, your capacitors look in good shape by the way. An no, this doesn’t cause trouble playing DCC’s; these capacitors are in the power supply so if they would be bad, you’d have bigger trouble.

To check what’s wrong with playing tapes:

  1. Use a known good cassette, e.g. a prerecorded cassette. If you don’t have prerecorded cassettes, at least use a cassette that has a brown pressure pad to make sure you’re not dealing with the sticky pad syndrome.

  2. Put the recorder in service mode to play your known good tape. For the 730, you do this by holding STOP and PLAY while turning the power on. Then push PLAY to play the tape. You should see a row of bits that represent each of the tracks. The digits should stay at 00000000 most of the time, maybe with an occasional bit going to 1 every once in a while. If one or more digits stays at 1 all the time, the corresponding track head is dirty or malfunctioning. Try to clean the head with isopropyl alcohol and a Q-tip. Sweep up and down, especially around the slit on the head. You can be quite rigorous but don’t overdo it of course.

If multiple tracks (or all tracks) show “1” while playing a known good section of a known good tape, it’s possible that your head is broken, e.g. because someone used a head demagnetizer. However if your recorder still plays analog cassettes, this is unlikely.

  1. If you hear any wow and flutter while playing an analog cassette, chances are that your pinch rollers need to be replaced. This is a very common problem on 3rd generation recorders.

Let us know how it goes.

=== Jac

1 Like

Thank you Jac for the extensive answer.
I did already replace the pinchrollers as well as the capstan belt and loading belt.
I have also cleaned the head with isopropyl.
The 730 still doesn’t play DCC tapes.
It finds and displays the time of the tape when winding the tape. But when Play is pressed it only shows lines.
I tried your suggestion of the service mode and this is what I got

The first 4 digits stay at 1 all the time. The second last digit flickers between 0 and 1. All the other digits stay at 0
I guess that my head is broken then?

Unfortunately that’s not good and could indeed mean that your head is broken.

However, because the missing tracks are the first 4 tracks and the last 4 tracks appear to work well, there’s still a chance that the head is just dirty or that there’s some mechanical problem. It’s even possible that there’s a problem with the flex cable between the head and the head amp board. Try unplugging it and plugging it back in.

Of course if you want to send it to the DCC Museum to get it repaired, you can contact Dr DCC

=== Jac

You can send in the mechanism if needed. We have replacement heads available.
Happy to help.

Ok, and how do I remove the flex cable from the amp board without damaging the cable?
It’s sitting underneith a white plastic clamp and I can’t get the white plastic piece to flip up so that the cable releases.
There’s a tiny spot on the flex cable that looks like it’s been poked with something.
The white plastic above that spot on the cable also has what looks like a poking damage.
Don’t know if that could be the reason for not reading dcc tapes.
But I can’t get the cable off from the amp board and I don’t want to just pull the cable without knowing if that’s the way to do it.

It is better to send the mechanism for testing.
2 screws will remove the entire block.
That way we can make sure it is not a read-write board problem f.i.

Yes I’m aware as how to remove the block, as I have changed the capstan belt on all of my four 3rd gen players. I was just trying to follow Jac’s suggestion of unplugging the flex cable and plugging it back in.
Thank you for all your support.

Ok. A firm, controlled pull is needed indeed, to remove it.

The white plastic part on that connector is fixed. The black part pulls out towards the flex cable (by just a millimeter or so; don’t try to pull it out any further) to release the cable.

From what I can see in the picture, the trace on the flex cable is not damaged by whatever that poking damage is. If you send the mechanism to Dr DCC, he’ll check it out I’m sure.


The cable with the red circle can be pulled (that is what I was referring to), the green circle is the one Jac mentioned.