DCC 600 no sound from a DCC tape

Hello everyone,

I bought a second Philips DCC 600. Hmm … actually got it for free. But no sound from a DCC tape. Also no result on the meters. The sound of an analog tape does work fine during playback. The mechanism seems to work normally. I cleaned the head with IPA Alcohol. There was a lot of dirt from it, but still no sound.

Anyone any idea how I can address this problem?



How well does it play analog tapes? If there is a lot of wow/flutter, you probably need to replace the belt(s).

Have you tried with a different tape? Preferably a DCC cassette with a brown pad to prevent the stick/shift problem.

Have you put the machine in service mode to see which heads are working and which heads aren’t? If some heads are working, it may be that the heads just need to be cleaned a little better.

Furthermore, check pinch rollers to make sure they’re not deformed, not eccentric and don’t have any irregularities. NB If this is the problem, the recorder might play one one side but not the other.


Thanks for your reply Jac,

The analog chrome tape used for the test sounds excellent. Just unbelievably good. But after every 10 minutes or so the sound fades away and comes back then sounds normal again. Several other analog tape sounded bad with a lot of distortion. Still dirty heads?

flipping from side a to b gives no problem.

I cleaned the head from the top without opening the mechanism. Perhaps that is not enough for a thorough cleaning.

Wich dcc tape should a use? I have 5 used ones and 6 new ones. All Philips brand. I will add a piciture of it.

No I havent checked the pinch rollers yet. I will if the first actions will have no result.

The service mode gives the following result:
With DCC in the tray
Side A 1 0(5) 5(10)(15)(20) (the digits are changing all the time) (after 2 minutes) it stops at

1 95 95 0000
after pressing “Text”:
DIG EYE CH 1 (after pressing Text) it inceases the last digit to 2,3,4,5,6,7,8

Side b 1 95 95 0000 (after 0.5 seconds)
after pressing “Text”:
DIG EYE CH 1 (after pressing Text) it inceases the last digit to 2,3,4,5,6,7,8

Can somebody explaines what these digits are telling? I guess its a indicator for the state of the heads?

I am on the road, but you can download the service manual from our website to learn about these numbers. The “blue drop” tape is usually the best.


1 Like

I swapped out the mechanism that contains the heads and r/w board. I guess the heads where worn out. Even the capstans looked wel used.

But its working fine now. Even the analog tapes sounds fine.

Thanks for all the tips and advice.


Don’t use it any further than absolutely necessary. It certainly was the cause for your problem, we have extensive documents on that matter.

1 Like

Noted Max :+1: