DCC 170 wont start after belt replacement

Hi, I’m looking for help / repair on my DCC 170. I replaced the belt on it according the instruction video from Ralph. However the unit won’t start any more after the repair. (it dit start / charge before).

I redid the whole repair twice, desoldering the board etc, still unit won’t start. Anybody that has an advice what tot do or would want to have e try at this DCC?

I’m located in NL near Eindhoven

I believe we had personal contact via PM.

You already double checked the tape selector switch and pushing down the lid mini switch.
It did not make a difference as I understood.

As no power is coming in, you should check the fuse on the main board. Next is to bridge the tape selector switch with a small wire (all 4 contacts). If the unit still does not turn un, bridge the mini lid switch. It will require serious dismantling.

It could also be the capacitors, although I have never seen these cause an issue not starting.

Alternatively , you can send it to us. We are happy to help.

Hi Ralph, thanks again for your answer and indeed we were in contact also via PM.
After some searching in the service manual I found the main fuse on the back of the mainboard, F806 in section 2C. measuring it had 1.5 Meg → so fuse blown. For now I solded a small wire over it, problem solved, player works like a charm. Now just ordering a 800 mamp SMD fuse and find the courage to replace it with my small heatgun. I tried to repair a r/w board of a DCC900 before, to replace the caps, that did not go well so for now I leave it and enjoy music on my DCC170 :slight_smile: