New Forum Member: 170 Starts up, PLAY displays then it shuts down... any suggestions?

DCC Forum,
I am the original owner of a DCC170 and after changing the belt it won’t play! I certainly hope I followed the service manuel accurately… the English is, well, not the best. I have certainly made mistakes along the way (one broken “hold” switch) so I’m open to any suggestion.

It fast forwards, rewinds, and enters Factory/Service Mode. I tried the AEGING test but it turns off when it tries to play.

Are there some details I may have missed as far as setting the internal mechanisms? I worked the lever at the solenoid until the “indicator” on the opposite side was set to stop (center position) and aligned the switch in the lower PCB when reinstalling. Could it be a defective belt?
I would really appreciate any help and advice.
Thank you

Did you make sure not to break the A/B reverse switch? Does the mechanism turn freely? Did you solder all the motor connections and switch connections back?


First of all, thank you for your response.

In response I would ask quite humbly, what (where) exactly is the A/B reverse switch?

To your other questions I can say that the mechanism turns freely, tapes fast forward and rewind at various speeds, and when open I can spin the motor and all the gears move as they should.
I also soldered all the motor connection to the best of my knowledge.

I will be desoldering once again soon and can post video and photos as the forum allows. Is there a particular image/video I could take to help solve the problem?

Thank you once again for your help.

The switch is on the bottom side of the bottom circuit board. There’s a hole in the board so you can keep an eye on it while you assemble it.

In the service manual on page 9 it shows it in a drawing. Unfortunately the drawing is wrong, it shows the A/B switch between the two capstans; however it’s on the far end of the capstans. They must have changed the mechanism.

I tried to edit the drawing to show where it is; I hope this makes it clear:

@drdcc made a video about repairing the DCC170 where he probably points out the location of the switch. Sorry, I don’t have time to watch the video right now to see if I can find any close-up shot of the A/B switch.

If you didn’t pay attention to it, it’s unfortunately very easy to break the switch (it happened to me once, too)… I hope it’s not too late for your recorder.


1 Like

Thank you again for trying to help me out.

My lower PCB is like the one in the service manual. The little window is between the capstans, and the switch and yoke ‘pins’ are visible. The switch is not broken! Thats good news.

I watched the video you linked to several times. Unfortunately drdcc is not precise enough with his language for an ignorant tinkerer like me. It has been years since I first replaced the belt and I have no recollection of the position that the yoke was in when I first disassembled the 170. There are only 3 possibilities though, right.

I tried setting the yoke to “Stop” as it says in the service manual, and aligned the switch with the yoke correctly. I soldered all the connections and reassembled. Unfortunately, the problem remains.

The unit powers on, ‘Play’ displays and the mechanism moves for a few seconds, then it powers off.

Unfortunately, as I was reassembling the unit I broke the tape sensor bracket. That is most likely the end of the project, as it’s 25 years old as it is… Maybe I can find another for parts?

I took pictures of each part as I reassembled if they are of interest to anyone here they are…

A final Thank You to you Jac!!


Hi and Welcome to the forum.
Don’t give up just yet.

The tape detection switch can be “helped” by soldering a small wire, touching all 4 contacts.
That way the player will always detect a tape, but you can move forward and worry about a replacement later (we have them in stock btw at the DCCMuseum).

The belt looks ok (is it 0.8/0.6 mm for sure?). Potentially it could be the motor, although it is weird that it would FFW.

After you solder the wire on the tape detection switch. Open the lid and hold the small white pin contact inside the lid pressed in and the press play while the lid is open and see if it spins without a tape.

Hello! And thank you for your suggestion. This forum has really been a pleasant surprise. I’m grateful.

I won’t have time to give this a try for a few days. I’ll post asap.

I don’t have a calliper to measure the belt so I’ll do the best I can.
Back in a few days…

I have the same problem, DCC170.
But mine does not rewind.

Order the right belt @drdcc